Adding Special Characters & Adding Unicode


#1

Hello Community!

I’ve noticed that while making my own font, I’m having issues with adding special characters such as copyright, trademark symbol, registered trademark. It just doesn’t show up when the font is complete.
I was wondering if anybody had that issue with special characters.

A suggestion I had In mind is to type the actual unicode so that the special characters show up when typing.

I’ll do my best to clarify with this image…


#2

Hi, so you should be able to type or paste the actual characters (©, ®, etc.) directly below each glyph.

Just switch back to the “Character” option from “Unicode” in the left-side panel, and enter the exact character.

And FYI you will be able to enter Unicode values instead in an upcoming update :wink:


Assign specific Unicode value to a character
#3

Good news, you can now enter HEX unicode values with the U+ prefix (like U+2655) to create specific glyph, or even rename your objects using this scheme to import many at once with Batch. Just install Fontself Maker 3.1.0 or newer.