Baseline not working and naming problem


I’m using AI CC 2015.3 + Fontself 3.5.7 and have a problem with baseline (positioning the object base height) + naming.
I’ve been following the instructions as outlined here and here.
Have all my glyphs named on separate layers and I also have my guides named.

When I drag multiple glyphs—along with the baseline guide—onto the batch window, none of the glyph names are correctly named (just shows the ‘null’ box; only works when draging to uppercase, lowercase & number) and the glyphs merge into 1 place (see pic 2).

[pic 1]

[pic 2 - with baseline]

[pic 3 - without baseline]

Am I only named the layer? How to named the actual objects?

[pic 4 - naming]

I also tried different methods of placing the baseline but the result is still the same.

[pic 5 - baseline placing]

[pic 6 - become uploaded separately]

Which part is not right? Please help. Thank you.


-SOLVED- (by email—thank you @franz)

Baseline: convert the horizontal path into an actual Illustrator guide by go to View menu > Guides > Make Guides.

Glyph naming: rename the Glyph objects (expand the layer—click the triangle icon)

Additional information:

  • When I press ‘Report a Bug’ menu from Fontself extension in AI nothing is happen (there is no pop up box or anything).
  • There is no ‘Editing Sign’ after directly edit the glyph (double click the glyph); for example I change the Left, Right & Bottom and the asterisk sign not appear on the title.

Yeah, I did the same mistake in the past - naming Layers instead of Compound Paths.

I think the tutorial needs more detail, because not all users are professionals in using AI/PS.

well, to be honest the guys at FontSelf are doing great job responding to support questions. And it is somewhat logical that if you are to create fonts in AI you must be at least proficient in the basics, yes?

Yes, they are.
haha… there’s a lot in basic that I need to learn; in font this is my first time learning to create it.