Can't install on intelliJ

Hello please help :cold_sweat:
I recently designed a monospace font on mac illustrator, and I sent both ttf & otf file for user testing, the font can successfully run on their PC system and microsoft files: word, powerpoint etc, but didn’t worked on intelliJ editor nor AndroidStudio. They can’t even find the name in the font setting list. we tried other font’s otf file download from google font and it worked fine.
Is there any solution for this situation? thanks!:pleading_face:

Under MacOS and Windows, in addition to the central font folder in some programmes, there is also a local font folder to which only the corresponding programme has access.

I have found that the two editors each have a local font folder. If you copy your fonts into this local font folder with the help of Windows, only then and after a restart of the programs can these fonts be used in the editors.

See screenshots.
Good luck
– j.

Thanks a lot!! it really helped

btw, why other typeface packages have no such issue on intelliJ? Is it because fontself not support this IDE yet? or is a programming thing haven’t figured out? if my font users can simply install on their pc and everything work fine would be the best

I myself have no idea why JDE behaves the way it does towards Fontself .otf. The main thing is that there is a way to use your own fonts with it.
good luck,
– j.