Corners not rounding

corners are not rounding for my “J”/“L”. tried flattening transparency and all patherfinder options
ive made almost 70 fonts and this is the first time its happened


remade it, couldn’t find a way around it. let me know if anyone else has had this problem

Hello 3xpyre,
I don’t know exactly what your problem is. If it’s about the rectangle that should have rounded corners, you have to do it like this:

  1. check the anchor points of the rectangle with cmd-Y (ctrl-Y). There must only be 4 of them. All other anchor points must be deleted by hand or by function (simplify).
  2. with the A key you can round off all or only one corner.

Good luck,
– j.

P. S. My AI file is attached here as a ZIP archive. (1.2 MB)

I remade them no problem. But as I can see the j was suppose to look like this. I dragged the j into fontself as you see here but like I said it removed the round corners in that top rectangle. It’s a basic shape to make some I’m no worried but if it happened on a more complex shape I wouldn’t know how to fix it…

I’ve made 70 fonts and I always clean all my anchor points up and flatten transparent etc and I’ve never had this problem before

As I described above:

  1. reduction to the most necessary anchor points with Object > Path > Simplify
  2. tools: Direct Selection Tool (A) go to the circle symbol and drag it, so the corners or one corner become round.

see also :

You don’t understand what I’m saying. The 25 other characters anchor points weren’t perfect but still the rounded corners transferred perfectly.

Hi, there is a bug in Illustrator since versions 25.3 which may result in such an issue.

Please upvote this bug request so Adobe fixes it asap:

2 temporary solutions until Adobe solves this:

  1. It should work fine if you load Fontself from an older version of Illustrator, like 25.2.3 or CC 2021. Check this link if you want to keep a copy of your older CC version to ensure backward compatibility:
  2. Or try to reset some internal settings by exporting any object as an SVG from File > Export As , then set the Decimal to 2 in the SVG options (as shown below). This may fix the Illustrator bug, and then restart AI and try again to import shapes into Fontself. This should prevent the error until they fix Illustrator in an upcoming release.