Forever Importing

I was playing around with a new font in Illustrator. The problem is that no matter what I do, I am always getting the “importing” ring but absolutely nothing ever happens. Running the latest version of Fontself and Illustrator, and yes of course I rebooted my computer. Am I missing something or is this a known bug?

Ok, check all of these steps, something on your computer might prevent the extension to run properly:

Ok so im totally new to fontself also so don’t know if im the best person to give advice:) But first time i tried importing with demo I did with Loki Cola font it worked perfectly and was no problem in exporting. Then when i imported my first own font and tried to export it it also came an loading import circle. So problem was one letter was not placed in the right position, it was too low. There did also appear a warning that i did not understand first the meaning :warning:…Then after i adjusted that one letter to the right position it worked! Hope you find a solution!

My workaround so far is that I load all character shapes at once, I cannot import 1 or 2 at a time at all nor add anymore after there are characters imported. Seems to work as an all or nothing import then map each character manually. It’s better than nothing I guess.

Fontself can still be kind of useful for getting the base characters into an otf then use a real font editor to do the work after the fact I guess.

if you select a letter and press on"create glyph" Then you can import anything separately.

Not for me for some reason these days. I’ve used this for quite a while already and know how the importing works. I’ve already made a few fonts with it already in the past, but I appreciate your help. Thank you.

In a nutshell importing does not work unless I select 4 or more glyphs no matter what. Weird glitch with it or something so I’ll just do what I can.

now i seem to have the same loading problem also. I get u it sucks!