Glyphs not showing up in Fontself

I have the following problem. I created 3 colored letters in Illustrator. Each letter has 2 colors.
After dragging them into Fontself, these letters do not appear, even though there seem to be place holders allocated to them.
See screenshot.
Please help

1 Like

Hello Roland,
welcome to this forum.

I tried it my self and I have no problem to create a three color font. You can check my .ai-file and the .otf-file. Perhabs you can see the/you problem.

Best regards, Jens (1.1 MB)

Servus Jens,
I think I have found what I believe is a bug in Fontself when you create glyphs that have 2 colors and you leage a small gap between shapes in the letter so that you have the background color showhing through.
In order to reproduce the bug, please use the edited ai file you had sent to me. I used Pathfinder to divide shapes between the grey color and white color. I then deleted the white color parts because I do not need them. The result is what I need each letter to look like: “shadow” of letter is color 1 and inside part is color 2. between those two there is the gap I need to have.
Please have a look at my edited file and try to drag the 3 characters into Fontself.
You will see that 3 glyphs have been added but each one is empty.
I just tried to upload the edited ai file which I had ziped. Unfortunately I get a message that as a new user I am not allowed to upload files. I would appreciate If you Could please give me rights to upload files.
I hope you understand my explanations.
Please try to reproduce.
Would you please confirm to me that this is a bug or perhaps there is another way to accomplish what I need.

Hello Roland,
I put you one level above in this forum.
You can send me the ai-file to my e-mail info(at)cg4u(dot)de

I have deleted the white elements. There are no overlaps between purple and grey in “C”, but there are in A and B. Nevertheless, all three letters are created without problems. See screenshot and ZIP archive.

  • jens. (1.1 MB)

Hi Jens,
I have created a short video showing the problem I am having. I used the latest ai file you had sent.
I have no idea why it’s working for you and not for me.
Maybe you find something by watching the video.
ThanksColor Font Problem Fontself (2.3 MB)

Hi Jens,
I have good news today. For some strange reason Fontself populated glyphs correctly after dragging them into the Fontself dialog window. I have no idea why it worked today but not before.
I can only speculate that perhaps the problem was/is related to your server generating characters. Maybe there was a bottleneck situation with internet connection that triggered the problem?
Please give me your thoughts.

Good morning,
I’m glad it’s working out now. I have no idea why it didn’t work for you and it did for me. It must therefore be a local problem. In such cases I always close AI and restart the programme. If in doubt, even restart the computer.
Kind regards


If you create your font as shown above, then the user cannot change the purple. But there is an alternative: Layered Fonts. I have created such a font with Fontself. This way, the user can choose whether to use all layers and in which colour. The disadvantage is that the user has to make sure that the glyphs are/remain in the right places. This works well in layout and vector programmes.

You can find the explanation of the procedure in German on my website:

1 Like