Illustrator crashes after adding a letter to Fontself


#1

I have the recently version of Illustrator and just got Fontself. I already have my letters done so I wanted to use Fontself. I added one letter then returned to Illustrator to add the next letter and when I clicked od the layer of the letter, Illustrator got stucked and then it crashed. I tried many times with the same result, crushing Illustrator. So I thought maybe it is the latest version of Illustrator and I installed the 2017 version but it happend again with the same result. What should I do?


#2

Hi Didi,

How are you adding your letters to FontSelf? I suppose what I’m really asking is, how did you create them? Sorry if this sounds patronizing, but just trying to get as much info as possible so that things can be ruled out and hopefully get to a solution quicker :slight_smile:

If your letters are vector format, make sure that they do not contain overly complex shapes (i.e. a rough edged character with a lot of small details. This would lead to each character having a lot of ‘points’, I think 1000 points per character is the limit, but I’m sure somebody can correct me on that if I’m wrong.) You can check that by selecting a specific character then going to Window > Document Info. Once that dialogue box has opened up, click on the hamburger menu icon in the top right of it and from the dropdown select object. This will display the number of points and paths your character contains. Try to keep your characters as simple as possible.

Another thing to bear in mind is not to have any raster graphics included, like adding texture with raster based opacity masks…or simply characters that are not 100% vector format.

I hope that helps and again, apologies if some of that seems obvious to you, but just trying to eliminate some problems and get to the solution for you :slight_smile:


#3

Hello,

thank you for your reply …I am using the fontelf template (Font template) … I add the letter by dragging it to fontself (any character Batch) choice and the fontself add the letter … by when I try go back to lllustrator it will crash.
I checked the points, 1 letter - 54 points … I dont have any raster graphic included.
I just find out that Illustrator crashes when i just click between Fontself to Illustrator, after few clicks it crashed without even adding the letter.


#4

Hi Didi :slight_smile:
Well if the characters/letters have that few points, we can rule that out as the issue. And also the fact its fully vectored. The only thing I can maybe suggest (if it doesn’t crash while you try it…and if you haven’t already), is to use the chat function in the FontSelf panel to contact the guys at Fontself directly too. They might know whats causing this. The only other thing you might want to try is to uninstall FontSelf and then reinstall it again…if that doesn’t work then reinstall Illustrator again…pain in the bum I know!

I would have said it was maybe a RAM issue, but if there are so few points in your characters and Illustrator is crashing without really being under any strain, I doubt that’s the issue, so maybe its some conflict in the installation?

I’m afraid, I can’t think on what else might be your issue. Hopefully somebody else does, or the guys from FontSelf can help :slight_smile: Good luck with it, I hope you get it sorted! If you do, let us know on here in case any one else is encountering the same problem.


#5

Hey @Didi please send the troubling AI file to hello@fontself.com so we can have a closer look, along with your app’s logs: https://help.fontself.com/troubleshooting/found-a-bug-send-us-the-logs

And thanks @twinbrush for your help, RAM can indeed become a constraint when working with large bitmap fonts in Photoshop.