Kerning in Photoshop extension


#1

Hi there,

I’ve worked on the kerning of my new font for quite some time, in batches(as I’ve noticed that the extension gets slower and even crashes if I keep on going for too long), saving my font as a new file after each batch, and then opening it each time when start with a new batch of kerning pairs. I’ve installed the font before I started with kerning, just to test it out. Then I removed it again(selecting remove complete family from Font Book). After all my kerning was done, I installed the font again, but when I type with it in Photoshop, there isn’t any kerning applied. If I open the most recent version in the extension and type there, the kerning is perfect. All I can think is that the first version of the font is somehow still installed somewhere on my mac, could you help me please? Restarting everything didn’t help.

Also, it would be amazing if we could just click on a ‘save’ button during the process of kerning, or even if there was an autosave function. I suggest this because I lost a whole day’s work twice in a row when my extension crashed(this happened every time after doing all my kerning, and then clicking on the home button to save the font), and it is heart breaking every time! That’s the reason I started batching, which works but just takes so much extra time! Just to mention, my font is not larger than the recommended size.


#2

Okay after deleting everything and clearing my system’s font cache, the problem persists, which means that it’s showing up my kerning pairs perfectly inside the extension but not applying them when the font is in actual use anywhere else. Please help!


#3

Hi Ria, I guess you’re working a bitmap font, which can grow pretty quickly in file size.

There is unfortunately an issue when handling such large bitmap font files (usually around 40-50mb) and while we’re addressing some of the underlying limitations in an upcoming release, this problem will still impact the largest files, and we don’t have a solution to detect when this limit is reached.

We actually also disabled the automated font backup process because of this issue, and can only recommend for now to keep processing the most complex fonts step by step, saving backup versions of your files, and avoid to put too many glyphs (or reduce the glyph size).

Hopefully we can solve this in the long term.


#4

Thank you Franz, I understand that the file size causes the slowing down of the extension and will work on making my bitmap fonts smaller in size. But could you perhaps help me with the first problem I mentioned:

Thank you!