Kerning pairs not saving


#1

I’m having issues with kerning pairs in Illustrator. I have quit and restarted IA fwiw.

As indicated in the pic below, I kerned a pair (“b” and “y”), saved, installed. But when the word “by” is displayed it shows the original kerning. I have tried resetting it and saving, moving it super close and saving, etc. but I can’t seem to get the line of text to display what is in the editor.

Has anyone else experienced this or perhaps can point me to what I’m doing wrong? I have this issue on a few other pairs as well, “SA” “AS” “fo”.

Thanks!


#2

I restarted AI again and this seems to have fixed the issue. /shrug

Leaving this here in case someone else has this problem, but seems like a bug – as I don’t think restarting should be required for viewing updates to the font.

Maybe a dev could speak to whether or not this could be an issue specific to using “Install”.


#3

Using the Install button should always relies on Illustrator’s ability to refresh the font file. To our knowledge, this type of unsynchronised display occurs only when a font is installed via the system font folder (or font manager) which will cache the first version of the font - until you restart host apps.


#4

Hi,

I have the same issue. I restart AI but the problem is not solved… (I restart everything)

The font is not installed in the system and is not in font manager…


#5

Problem solved…

I write e new text and select my font. Kernings appeared…


#6

Cool, glad you made it work :wink: FYI there is still an issue with alternate glyphs, which won’t show up properly kerned in the bottom left preview. This is something a bit tricky to solve, but all other characters should be kerned properly. Let us know otherwise.


#7

Hey there, I’m having a similar problem too with the kerning pairs.

The kerning works fine in illustrator, but when I try to use the font in word or sketch the font file seems to have forgotten all of the kerning pairs.

Anyway suggestions to fix this?

Cheers