Microsoft word problem using font (codepage?)

I experimented creating a font with English glyphs. I also added one by one Greek glyphs. I created otf font and tried to use it in word 2018. Everything great. One big problem. When inserting the insertion point inside text and add characters word applied the default calibri font. I select everything and reapplied my font. It was corrected. I opened the font with fontlab. In the font info dialog box at the codepages submenu only 1251 English codepage was applied. I added 1253 Greek codepage and regenerated otf font. (I tried both binary and compiled options for the exporting of the kerning information i had aplied at fontself). That corrected the problem at Word. The new otf file was half the size of the original that was generated by fontself. BUT the new font file couldn’t open anymore by fontself.

My question is:

Where in fontself menus can I apply Greek codepage support at first place.

Why the fontlab generated font can’t open anymore at fontself?

If you assign the correct unicodes to your letters in Fontself, there should not be any problems in WORD.
I assign the names of the glyphs directly in the “Layer” window and have written a Javascript for renaming from and to Unicode:
see (German page).
You should choose a character set that is as complete as possible as a model.
Regarding your last question: This is also a security measure so that no foreign fonts can be edited in Fontself. But of course there are also technical reasons, namely to maintain the editability of the Fontself font.

Good Luck,
– j

i assigned correctly the names of the greek glyphs. I see them correctly in Word. Why though in fontlab the font seems not to have assigned the 1253 greek codepage? Probably that is the reason why word cant maintain the same font when you type new characters in between the text. InDesign dosnt have the same problem though.