Problem when copying text that uses coloured .otf

When I want to use a coloured font created with Fontself Maker in Adobe Illustrator 2020 and 2021 under macOS, I have noticed the following:
If a string is written with the coloured font and then copied, the text of the copy turns into a group with paths. And is therefore no longer editable.
The problem occurs with all my coloured fonts that I have created with FS.

This behaviour only occurs in AI macOS, under Windows everything is fine. Other vector programmes, as far as they support coloured .otf, do not cause any problems either. Also the coloured font Gilbert-Color can be copied and the copy is still text.

Is it a bug in AI macOS?Or a problem when creating coloured fonts with FontSelf Maker 3.5.4 and earlier versions?

The problem does not occur in Photoshop 2021 or InDesign 2021.

Hey Jens. I tried to replicate your issue and I couldn’t - the copied text is copied as text and pasted normally in AI - I’ve tested with my Cimero Pro font. Feel free to test with it, maybe?

Or tweak your clipboard preferences within Illustrator?

Hello and thank you for the great font.

I tried it in my Adobe Illustrator 2021 (25.2.3) AND Adobe Illustrator 2020 (24.2.3) on 2 Macs (macOS 10.14.6 and macOS 10.15.7) also with your font.
After restarting the computer, the first copies of a text with a coloured .otf font created with Fontself remain text. But after a few copies, the new ones are suddenly converted into groups (no longer editable).
It is probably a problem with the coloured .otf fonts.

Hey, cannot reproduce this either. If it happens randomly, then sounds more like an issue with the host app (color fonts are still leading to edge cases that Adobe’s team are fixing… step by step :slight_smile:

ok, thanks. I will have try it withe the next updates of AI.

So, I tested this again:
I use a coloured font created with FontSelfMaker 3.5 to write three letters like “ABC”. I now want to copy them. Illustrator offers several possibilities:

  1. copying with cmd-C, cmd-V in Illustrator 2021 and 2020 under macOS 10.14 and 10.15 creates a group instead of a changeable text as if the command “convert to paths” was called. This always happens, even if not immediately. Sometimes the first copy still works.

  2. copy with move and pressed option key. No problem. The text remains in the copy text.

  3. copy with transform with activated hook for copy (cmd-D). The text remains in the text copy.

Have a good start into the new week.