Fontself breaks some shapes

Hello! I am using fontself to create some fonts for my lettering generator. And I love how it’s working.

Now I have a problem I can’t solve. Fontself seems to break some of my shapes and I have no idea why.

I created a rope lettering font and most of the letters work fine.
But some of them get somehow distorted on import altough the shapes are made exactly the same way like the all others.

Any ideas why that happens? And what I can do?

Thanks!

Hello Timo and welcome to the forum.

Unfortunately, I don’t see the problem in your example. Can you put the two letters A and B as an AI file here in the forum so that I can try it? Thank you.

BTW: Are you using AI 25.3 with Fontself 3.5.6 under which operating system?

Greetings, Jens.

Thanks for the fast reply! You have to take a closer look. The shapes of the rope are destroyed on the “A” sometimes. I created a new file for you and when I dropped the letters from there to my font it works on the “A”, but another try with an “Ä” does not work perfect.

I am running the newest versions (AI 25.3.1, FS 3.5.7, WIN 10).

I can’t upload a ZIP as a new user, so I uploaded it to gdrive: https://drive.google.com/file/d/14e_FKnIqqawLT6WBnHx485cCwv7P0mRw/view?usp=sharing

Thanks!

ok, thanks, I will check it.

Hello, I have tested your file. I could not find any problem. See screenshot. If you don’t have enough white space to the right and left of the letters, you can use the SMART function in Fontself to automatically generate optimal spacing.

Greetings, Jens.

Archiv.zip (1.3 MB)

Thanks again for taking the time!
On your screenshot most shapes are fine but there is one point which shows the issue:


If you zoom in in AI you should see it better.
Thats the same behaviour like in my first screenshot.
The lines are somehow flattened.

ok, I see. I have no idea why this is happening. But I’ll pass it on to the programmers.

Thanks @urs7000 for your support to the community :muscle:
Hey @timoostrich, Could you send me your AI document right from the chat bubble in the extension?

1 Like

Hi, we just heard from Adobe’s team that there is a bug since Illustrator versions 25.3 which may result in such an issue. Please try to export any object as an SVG, then set the Decimal to 2 in the SVG options. This should prevent the error until they fix Illustrator in an upcoming release.

At the moment I am using AI 25.2 which works perfect. The bug came up with the newer versions. I will stay with 25.2 for the moment.